kuinka korjata shellshock haavoittuvuus vanhasta ubuntusta apt get

1. tarkista onko järjestelmä haavoittuvainen:
env X="() { :;} ; echo busted" `which bash` -c "echo completed"
järjestelmä on haavoittuvainen jos näet busted ja completed tuloksena

2. tarkista julkaisun nimi(esim: saucy)
lsb_release -a

3. hae ja vaihda julkaisun nimi apt listalle
sudo sed -i 's/saucy/trusty/g' /etc/apt/sources.list

3. päivitä bash:
sudo apt-get update
sudo apt-get install --only-upgrade bash

4. tarkista järjestelmä uudelleen:
env X="() { :;} ; echo busted" `which bash` -c "echo completed"

5. vaihda apt lista takaisin
sudo sed -i 's/trusty/saucy/g' /etc/apt/sources.list